Announcement

Collapse
No announcement yet.

eSignal VS Code Plugin Issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ewdeg98
    replied
    Appears to be fixed with extension version 0.30.1

    Leave a comment:


  • demarcog
    replied
    I am having a similar problem.

    Is anyone successfully using the debugger?

    Is there any documentation available aside from the 1 paragraph "quick start"?

    thank you

    Leave a comment:


  • ewdeg98
    started a topic eSignal VS Code Plugin Issues

    eSignal VS Code Plugin Issues

    Hi, I'm having issues with both the Intellisense and Launching / Debugging EFS scripts. (v0.26.0)

    For Intellisense:
    Using the command to install the types:
    eSignal: Download EFS Types

    I get the following error:
    Command 'eSignal: Download EFS Types' resulted in an error (command 'esignal.downloadTypes' not found)
    Documents/Interactive Data/Formulas/My Formulas/eSignalTypes/types.d.ts' not found."

    Found in Log (Extension Host)
    [2020-06-11 11:52:34.526] [exthost] [error] Activating extension eSignal.script-debugger failed due to an error:
    [2020-06-11 11:52:34.527] [exthost] [error] TypeError: Cannot read property 'call' of undefined

    I added the following statement to my currently open EFS, however it does not make a difference:
    /// <reference path="eSignalTypes/types.d.ts"/>

    For Launching / Debugging:
    I've created the launch configurations, eSignal is running with a chart open on a page.
    I then click the Start Debugging icon, it appears to run for a few seconds (shows debugging tools at top of screen) but then quits afterwards. I do not get the option to select the eSignal chart to insert the script as seen in the demo, and the breakpoints, callstack etc shows nothing

    eSignal v12.14
    Last edited by ewdeg98; 06-11-2020, 10:06 AM.
Working...
X