No announcement yet.

IB plugin problem

  • Filter
  • Time
  • Show
Clear All
new posts

  • IB plugin problem

    I was able to place order thru IB plug in before. However, after upgrading to eSignal 10.6.2124.1086 and IB plug in 1.2.2127.911 I can get connected but can't place order ("New Order" and "Symbol Mapping" are left grey).

    I got below messages when I run the plug-in configurator:

  • #2
    Try re-installing everything, especially eSignal.
    It worked for me when I had some bugs.

    If re-installing doesn't work, uninstall and delete all, before you install again.
    Save your Layouts and Pages to another folder or drive.


    • #3

      The error message you're receiving is from Interactive Brokers, generally this error "No Security Definition found" mean that an instrument that you're currently holding or did hold in the past 24 hours is missing a key piece of information need to populate the Account Manager.

      In working with this error we've found that about 95% of the time it's related to an exchange being equal to NULL instead of the exchange the instrument was traded on.

      What we're going to need to resolve this is the TWS Logs that are created. I'll PM you the instruction need to get the logs. Once we've gotten the log we'll know better what need to be done. Or you can contact IB and they too can show you how to get the logs.


      • #4
        Avery, can you send me the PM so I can check?


        • #5
          Avery, I have replied the PM a few days ago.

          Would you please advise whether there is any update?


          • #6

            Please confirm you've received my email with the explanation from Interactive Brokers about the error message you're receiving.

            Interactive Brokers is reporting that they do maintenance on their servers from 11:30 PM to 1:00 AM EST each night. From the explanation it appears this is the same time that you're trying to log in which prevents your portfolio from download. There was not suggested workaround as to how you can prevent at this time. I'll continue to work with them and keep you posted.


            • #7
              Sorry but it should not be only related to below reason only. It is because it has failed to work for 2 weeks already

              I have tried again and below is the error msg:

              In eSignal, the status bar shows that IB is connrected

              However, the buy/sell buttons are greyed out

              The menu has many items greyed out too


              • #8

                It may be necessary to get a new set of logs from you. I would say that if you're still unable to connect before noon or after 2PM HKT then we would need to consider that something else is the issue. If you could email your logs from today and yesterdays we can go through and see if there a pattern to the connection problem.


                • #9

                  Your login error looks a lot like my optionxpress connectivity log... it has not worked for months.

                  I was thinking of switching brokers to avoid my problem but you seem to be having the same issue with the IB pluggin.

                  I'm posting here to watch for a solution for you as I'm desparate for something that works.

                  Cheers, Eugene


                  • #10

                    I am receiving "no security definition has been found for the request". I have the auto mapped the esignal NQ H19 to the Interactive Broker Symbol.

                    Anyone have any idea why I cannot place an order for this symbol.

                    Thank you very much.

                    Glen Demarco